Mod Compatibility (MineFactory Reloaded)

From Feed The Beast Wiki
Jump to: navigation, search

This page documents some of the compatibilities of some mods with MineFactory Reloaded (also known as MFR).

All Minecraft Forge mods are compatible with each other to some extent, simply because they are using Minecraft Forge. To avoid the use of the terms "compatible" and "incompatible" in this article, we shall define new compatibility levels as follows:

  • Level 1 Compatibility mods are basically mods that any MFR user should consider adding to their mod list.
    Mods under this category should:
    • Require no config editing to do at all. The mod should work with MineFactory Reloaded by default.
    • Provide stuff that MFR cannot not provide on its own.
  • Level 2 Compatibility mods are mods that are still interesting to MFR users but have minor issues.
    Mods will fall under this category if:
    • They have issues that can easily be fixed with some straight-forward config editing.
      Straight-forward config editing is, for example, setting a value from true to false in a config. Anything more complicated than that will fall under the next category.
    • They have minor issues which can easily be worked around (if the issue cannot be fixed with straight-forward config editing).
  • Level 3 Compatibility mods are mods that might be problematic for the average user.
    Mods will fall under this category if:
    • They might cause unexpected problems.
    • The issue is quite severe and requires more work than straight-forward config editing to get them to work with MFR. For example, MineTweaker or writing any sort of mod to fix problems.
    • They do not fall under previous categories.

This wiki will not document all Forge mods. Most Forge mods will at least be Level 2 Compatible. The few mods that are Level 3 Compatible are mods that either make a LOT of changes to Minecraft or are written by their authors so that they are not compatible with other mods.

Should you run into problems, remember that you can try asking for help on the forums or relevant IRC channels.

Level 1 Compatibility[edit | edit source]

Applied Energistics[edit | edit source]

MineFactory Reloaded will allow for some of its blocks to be used in P2P Item Attunement with various commands.

Atum[edit | edit source]

MineFactory Reloaded will allow for Atum plants to be used with the Planter, Harvester, and the Fertilizer. Some Atum entities are blacklisted from the Grinder and the Safari Nets.

BackTools[edit | edit source]

The Spyglass, Safari Net Launcher, and Precision Sledgehammer will be custom rendered onto the player's back with BackTools installed.

BuildCraft[edit | edit source]

New Facades will be added by MFR, and BioFuel will be able to be used as BuildCraft fuel.

ChocoCraft[edit | edit source]

MineFactory Reloaded will allow for ChocoCraft plants to be used with the Planter, Harvester, and the Fertilizer.

ExtrabiomesXL[edit | edit source]

ExtrabiomesXL's plants can be used with the Planter, Harvester, and the Fertilizer.

Forestry[edit | edit source]

Forestry Fertilizer and Compost can be used in the Fertilizer from MFR. Bituminous Peat, Ash, and Decaying Wheat will be able to be made with the Sludge Boiler. Forestry plants will be able to be used with the Planter, Harvester, and the MFR Fertilizer. Bog Earth can be used as a Dirt replacement with machines.

Level 3 Compatibility[edit | edit source]

IndustrialCraft 2 (IC2)[edit | edit source]

This mod would be considered Level 1 if it did not add a possibly problematic Ore Dictionary entry. The compatibility with IC2 is extensive:

  • IC2 Rubber trees and crops can be harvested, planted, and fertilized. The Sticky Resin spots will be considered a fruit.
  • A new Plant Ball recipe is added.
  • BioFuel can be used in the Semi-Fluid Generator.
  • MFR adds an OreDict entry to Leather Boots as greggy_greg_please_do_kindly_stuff_a_sock_in_it. This can become problematic when writing MineTweaker scripts or other mods for modpack development. A MineTweaker script or a new mod can be written to remove this entry.

SquidUtils[edit | edit source]

SquidUtils, as a response to the greggy_greg_please_do_kindly_stuff_a_sock_in_it OreDict entry and the four rejected pull requests to remove it[1][2][3][4], adds a console message when it detects that OreDict entry exists:

  • A normal warning: Skyggy_sky_please_do_kindly_shut_up, the amount of times the message is printed may be changed in the config.

It also adds a console message when an OreDict entry has more than 20 symbols (can be turned off in the config).

  • A large warning: Too long oredictionary entry!

References[edit | edit source]